Problem z apt-get /usr/local/lib/libz.so.1: no version information

Z Podręcznik Administratora by OPZ SGU
Skocz do: nawigacja, szukaj

Próba instalacji za pomoca apt'a lub aptitude na systemie debian 6 64 bit powoduje wyswietlenie komunikatu

aptitude: /usr/local/lib/libz.so.1: no version information available (required by /usr/lib/libapt-pkg.so.4.10)
/usr/lib/apt/methods/http: /usr/local/lib/libz.so.1: no version information available (required by /usr/lib/libapt-pkg.so.4.10)

trudno mi powiedzieć z czego on wynika jednak powodem jest złe dowiazanie biblioteki

w celu naprawy wykonujemy nastepujace komendy:

rm /usr/local/lib/libz.so.1.2.3
rm /usr/local/lib/libz.so.1
ln -s /usr/lib/libz.so.1.2.3.4 /usr/local/lib/libz.so.1